CVE-2019-11043 — PHP security advisory
CVE-2019-11043: In some versions of PHP in certain configurations of FPM setup, it is possible to cause FPM module to write past allocated buffers allowing the possibility of remote code execution.
Risk and impact
The vulnerability allows remote code execution in PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24, and 7.3.x below 7.3.11 in certain FPM configurations. This could lead to unauthorized access, data manipulation, or system compromise.
Recommended action
Apply updates per vendor instructions. Ensure that affected versions are patched to versions 7.1.33 or higher, 7.2.24 or higher, and 7.3.11 or higher, respectively.